ClickTale Support Forums

All times are UTC - 6 hours



Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Sep 19, 2012 12:04 pm 
Offline

Joined: Fri Jul 27, 2012 10:48 am
Posts: 2
In the progress of implementing Clicktale into an Asp.net MVC 3 site

In the web.config we have The WhiteListURLRegex, which lists the pages we want to record

Code:
<ClickTale.IntegrationModuleSettings ScriptsFile="~\ClickTaleScripts.xml" DoNotProcessCookieName="WRUID" DoNotProcessCookieValue="0" MaxCachedPages="100" WhitelistURLRegex="(Home\.aspx|Shop\.aspx|About\.aspx)" AllowedAddresses="x.x.x.x/x"/>


Since MVC sites dont have .aspx files, how would the WhiteListURLRegex work? Just use the Action names?

Home.aspx => Home\Index
Shop.aspx => StoreFront\Shop
About.aspx => Information\About

Should it look like this:

Code:
WhitelistURLRegex="(Home\Index|StoreFront\Shop|Information\About)"
or maybe like this
Code:
WhitelistURLRegex="(Home|Shop|About)"


Thanks much


Top
 Profile  
 
PostPosted: Wed Sep 19, 2012 12:14 pm 
Offline

Joined: Wed Nov 02, 2011 1:39 am
Posts: 128
Hello Hans,

Please use this special link: http://subs.clicktale.net/CustomerSupport.aspx?ticket=#### to send a ticket to our support team, so we can investigate this matter further.
Note:
#### is the topic number from viewtopic.php?f=1&t=####
You can use the above text as is- it's already formatted to fit the syntax constraints of the forum.

Regards,

Sergei


Top
 Profile  
 
PostPosted: Wed Sep 19, 2012 1:11 pm 
Offline

Joined: Fri Jul 27, 2012 10:48 am
Posts: 2
Thanks Sergei.


If anyone else has implemented Clicktale on an MVC 3 site - any tips would be appreciated


Top
 Profile  
 
PostPosted: Thu Jan 09, 2014 12:57 pm 
Offline

Joined: Thu Jan 09, 2014 12:52 pm
Posts: 3
Hans,

Based on the information in the ASP.NET integration module wiki (http://wiki.clicktale.com/Article/Help_talk:ASP_NET_integration_module_v1#There_is_a_specific_page_that_I_don.27t_want_recorded.2C_but_the_module_adds_ClickTale_script_to_every_page) it should pick up on the URLs even without the file extension since it's just a regex.

However, I've been struggling to get it to actually work. I've added the WhitelistURLRegex attribute to the ClickTale.IntegrationModuleSettings element in web.config. I've also tried adding the attribute to the Scripts ans Script elements in ClickTaleScripts.xml. None of these locations seem to work though. The tracking code is still added to every single page in the site. Has anyone gotten this whitelist to work with ASP.NET MVC?


Top
 Profile  
 
PostPosted: Fri Jan 10, 2014 3:57 am 
Offline

Joined: Mon Oct 28, 2013 7:40 am
Posts: 24
Greg,

ClickTale is not aware of any bug with the WhitelistURLRegex attribute added to the modules web.config file .

There might be that the regex you are using is wrong.

I would recommend testing it using any regex tester.

In addition you should check that the WhitelistURLRegex is written correctly:

WhitelistURLRegex="(page1\.aspx|page2\.aspx)"


Top
 Profile  
 
PostPosted: Fri Jan 10, 2014 5:25 pm 
Offline

Joined: Thu Jan 09, 2014 12:52 pm
Posts: 3
Is the file extension required? I'm simply trying to whitelist only the URLs in a specific area of the website. Each URL with follow the basic pattern of http://<my domain>/PublicPortal/<the rest of the URL>. My WhitelistURLRegex attribute is set in the web.config settings as follows
Code:
<ClickTale.IntegrationModuleSettings
    ScriptsFile="~\ClickTaleScripts.xml"
    WhitelistURLRegex="(PublicPortal)"
    ...
/>


I've tested this in RegexHero.net and it properly finds the "PublicPortal" part of the URL, so it should match correctly. However, all pages on the site contain the tracking code and are recorded.


Top
 Profile  
 
PostPosted: Wed Jan 15, 2014 11:58 am 
Offline

Joined: Wed Nov 02, 2011 1:39 am
Posts: 128
Hi Greg,

How old is the .NET module you're trying to add this feature to? This is something that has been added rather recently, and is not supported by older versions of the module. Please let me know the version of your ClickTaleIntegrationModule.dll file.

In case you have the most recent version of the module, please try using the following instead: WhitelistURLRegex="(.*PublicPortal.*)"

Sergei

ClickTale


Top
 Profile  
 
PostPosted: Wed Jan 15, 2014 12:27 pm 
Offline

Joined: Thu Jan 09, 2014 12:52 pm
Posts: 3
Hi Sergei,

I'm using 2.3.0.0, which is the latest version according the to ASP.NET integration module wiki page. I've also made the changes to the regex as you suggested and confirmed the change via the ClickTaleDebug.ashx page. However, the ClickTale tracking code still appears on all pages.

Thanks for the help so far. Anything else you can suggest that I try?


Top
 Profile  
 
PostPosted: Thu Jan 16, 2014 9:38 am 
Offline

Joined: Tue Apr 17, 2012 12:55 am
Posts: 44
Hi Greg,

Could you perhaps change the case to all-lower-case like so:

Code:
<ClickTale.IntegrationModuleSettings
    ScriptsFile="~\ClickTaleScripts.xml"
    WhitelistURLRegex="(publicportal)"
    ...
/>



Please let me know if this doesn't resolve this issue.

Best,


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group